Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Game launching issue

I bought Casey Powell Lacrosse 16 on Steam yesterday.

When I tried to launch it, Steam had an issue and I needed to shut it down. When trying to launch Steam again it said that I'm already plaing Lacrosse 16. I checked my task manager and nothing appears so I rebooted my laptop and opened Steam again but had the same issue saying that I'm playing.

I can open any game, but my Steam account will say I'm playing Lacrosse 16 and not the one I just launched.

Anyone having the same issue ? I saw on the Steam store that an user had many downvotes for his review on the game and it looks like I've got the same issue as him.

I'm trying to play with a Windows 8.1 laptop with an Intel i7-4750HQ @2.00GHz

Hope you can help me with my issue, thanks in advance.
(03-17-2016, 12:39 AM)Punky41 Wrote: Hope you can help me with my issue, thanks in advance.

Sorry to hear this @Punky41, someone from Big Ant will be in touch within 24 hours to try and help.

Big Ant Studios store at

Thanks for the feedback but it looks like the game works now, Steam just took a little time to launch the game but after a few tries I can launch it.

Thank you,

Forum Jump:

Users browsing this thread: 1 Guest(s)